Ford Mustang Forums
 Home Register FAQ New Posts Members List Contact Us     Log In Log In  
 
Ford Mustang Forums Tech Related Engine & Performance

Fuel, spark but no start

snowman 16.03.2015, 20:48
On my 12.5-1 300ci inline 6.
Got into a tight spot and needed more power to pull through so sprayed 250 like usual, had a backfire through carb at 8******0. Let out, engine idled then died. Checked power at dizzy and plugs, good. Good fuel pressure and carb is squirtin(850cfm 4150). Engine just cranks and getting fuel and spark and turns over, any ideas?
hotrodkid05 17.03.2015, 14:01
Have you checked compression? Do the 300s have timing gears or chain? If it has a chain it could have jumped and your timing might be off. Also, I'd love to see this thing run. I used to want to beef up a 300. They are stout little motors.
snowman 17.03.2015, 16:01

Originally Posted by hotrodkid05:

Have you checked compression? Do the 300s have timing gears or chain? If it has a chain it could have jumped and your timing might be off. Also, I'd love to see this thing run. I used to want to beef up a 300. They are stout little motors.

Its not the Ford 300, it started out a Jeep 4.0 that has been bored and stroked to 300ci. Its a chain, motor has had 1 oil change after break in(less then 550 miles on motor). Im gonna try and do a vac/compression test this weekend. Your probably right it jumped time; hopefully, if not then it must have burnt a hole in all 6 pistons or washed all the cylinders out.


SCAT forged 43/40 H Series rods
RaceTec 12.5-1 pistons
TotalSeal rings
Heavily ported Hesco cylinder head
custom ground camshaft
Offy 6-******0 intake etc etc etc

If I can get it to fire again Ill post a video, it made 509rwhp/515rwtq with out the bottle going through a big ass power robbing SM465/Dana 300 and 35's.
donsbad89 18.03.2015, 00:12
Hurt a piston.
broke again 18.03.2015, 14:26

Originally Posted by snowman:

Its not the Ford 300, it started out a Jeep 4.0 that has been bored and stroked to 300ci. Its a chain, motor has had 1 oil change after break in(less then 550 miles on motor). Im gonna try and do a vac/compression test this weekend. Your probably right it jumped time; hopefully, if not then it must have burnt a hole in all 6 pistons or washed all the cylinders out
SCAT forged 43/40 H Series rods
RaceTec 12.5-1 pistons
TotalSeal rings
Heavily ported Hesco cylinder head
custom ground camshaft
Offy 6-******0 intake etc etc etc

If I can get it to fire again Ill post a video, it made 509rwhp/515rwtq with out the bottle going through a big ass power robbing SM465/Dana 300 and 35's.

That is crazy power out of 300 ci na. I would hate to try and foot the bill for a ford 302 build to approach that type of rear wheel hp, much less a straight 6. what is the the rod length on something like that?
snowman 19.03.2015, 12:34

Originally Posted by broke again:

That is crazy power out of 300 ci na. I would hate to try and foot the bill for a ford 302 build to approach that type of rear wheel hp, much less a straight 6. what is the the rod length on something like that?

Theres easily over 11k in motor, rod is 6.150
Similar Threads
Wont start no spark need HELP!!!
Anyone work on quads? 06 Grizzly wont start. Seems to be a spark issue.
spark advance, fuel, and octane.
94 GT fuel pump runs with key off no spark no injector pulse
No Spark.
Copyright © 2006-2019, Ford Mustang Forums. Privacy Policy