Ford Mustang Forums
 Home Register FAQ New Posts Members List Contact Us     Log In Log In  
 
Ford Mustang Forums Tech Related Engine & Performance 5.0 Pushrod Guys

Need some info.

Page 1 of 2 1  2 
mylittleponie 22.08.2014, 01:27
Ok guys I'm stumped here! Got a 95 gt 5.0 with auto. Current mods are cam that's a round.544 lift and a cold air intake with a sct 90mm. Adjustable fuel reg World sr heads 1.6 rocker and has cobra upper and lower, has no cAts with shorty headers! It's throwing a p0******65. Has a sct 6600 chip also but I don't think it's tuned right! Read everything I can about all this! It runs rich! I adjust the fuel pressure to 40lbs with vacuum line off. What route should I go? Get the chip retuned or what?
mylittleponie 22.08.2014, 01:30
Oh ya has 24lbs inj
10seclx 22.08.2014, 01:38
Just a thought but is the mass air calibrated for the 24# injectors?
mylittleponie 22.08.2014, 01:48
We'll I was told it was but I'm not 100% on it! I got the car this way and trying to figure out the bugs
hotrodkid05 22.08.2014, 02:04
Did you buy this car from Choctaw area?
mylittleponie 22.08.2014, 02:26
Yes I did!
hotrodkid05 22.08.2014, 02:37
Ok. Thought it sounded familiar. I know who you bought it from.
hotrodkid05 22.08.2014, 02:43
552 - Air management 1 circuit failure*
553 - Air management 2 circuit failure*
556 - Fuel pump primary circuit failure*
558 - EGR vacuum regulator circuit failure*
565 - Canister purge circuit failure
P0121 In-Range Operating Throttle Position Sensor circuit failure.*
mylittleponie 22.08.2014, 02:48
I built the car then had to sell it in my divorce! 6 yrs later I have it back and trying to figure out how to get it running! Put new plugs in cause they were fouled and gapped wrong. Cleaned mass air and it ran bad ass. But now chip light is on and won't run good. Even with chip out does exact same
hotrodkid05 22.08.2014, 02:53

Originally Posted by mylittleponie:

I built the car then had to sell it in my divorce! 6 yrs later I have it back and trying to figure out how to get it running! Put new plugs in cause they were fouled and gapped wrong. Cleaned mass air and it ran bad ass. But now chip light is on and won't run good. Even with chip out does exact same

Yep he had the same problems. I tried to get him to get it retuned but he wouldn't listen to me. I'm pretty sure you don't need that chip junk on there. I even called Bo Woody for him and talked to him about it. Idk who he took it to in the beginning. I think it was Oklahoma performance something but I can remember.
mylittleponie 22.08.2014, 11:11
Yea he had opa tuning do it but they no longer in business. I really think it does need retune. How do I get ahold of Bo woody?
10seclx 22.08.2014, 11:33
Those old cars were pretty simple can you not just pull out the chip mess with the timing and fuel pressure and be fine with it
hotrodkid05 22.08.2014, 11:51

Originally Posted by mylittleponie:

Yea he had opa tuning do it but they no longer in business. I really think it does need retune. How do I get ahold of Bo woody?

424-race. I guarantee it needs a tune. It may have another issue as well but it needs retuned.
mylittleponie 22.08.2014, 12:29
Yes it does and thanks for the info!
hotrodkid05 22.08.2014, 12:31
No problem man.
Page 1 of 2 1  2 
Similar Threads
Info on my car
I need some Info....
g1 info
any info on this car?
Just some INFO
Copyright © 2006-2018, Ford Mustang Forums. Privacy Policy