Ford Mustang Forums
 Home Register FAQ New Posts Members List Contact Us     Log In Log In  
 
Ford Mustang Forums Tech Related General Tech/How Do I?

Led tail light problem

Csperry84 12.07.2014, 19:18
Look i know this is probably an old thread but i really need some help before i eff something up. I recently bought 6 ******9smd red led bulbs for the tails on my 98 and while being a noob i though i could just plug em in and go well not the case i already have sequentials so i really would like the look of leds and sequentials. So any way i plugged them all in and none of them work unless i press the brake all of em work with the brake depressed but when i let off and turn my headlights on only one comes on the inner one closest to the trunk and when i turn my signals on only outer two are on and flash rapidly well i found out i probably need resistors and maybe a electronic flasher relay so i bought 6 resistors and yes the resistors slowed the flash but did not work when i went to turn my running lights on still no light only when i press brakes anyhelp would be greatly appreciated ive searched high and low for answers and most people just have the rapid flash problem but my wont even come on when turn the lights on and yes the polarity of the bulbs is right because when i press my breaks they all come on im just about to give up amd just live with i wasted my money on led bulbs ill never use before i fuck sumn up
Csperry84 12.07.2014, 19:33

Originally Posted by Csperry84:

Look i know this is probably an old thread but i really need some help before i eff something up. I recently bought 6 ******9smd red led bulbs for the tails on my 98 and while being a noob i though i could just plug em in and go well not the case i already have sequentials so i really would like the look of leds and sequentials. So any way i plugged them all in and none of them work unless i press the brake all of em work with the brake depressed but when i let off and turn my headlights on only one comes on the inner one closest to the trunk and when i turn my signals on only outer two are on and flash rapidly well i found out i probably need resistors and maybe a electronic flasher relay so i bought 6 resistors and yes the resistors slowed the flash but did not work when i went to turn my running lights on still no light only when i press brakes anyhelp would be greatly appreciated ive searched high and low for answers and most people just have the rapid flash problem but my wont even come on when turn the lights on and yes the polarity of the bulbs is right because when i press my breaks they all come on im just about to give up amd just live with i wasted my money on led bulbs ill never use before i fuck sumn up

please hel me for im about throw this junk in the trash and just live with only have my license plante and third brake light led :( :(
jrhaden 12.07.2014, 20:04
Try turning them opposite of how they are plugged in. Some are +/- and have to be plugged in certain way.
Csperry84 13.07.2014, 05:54
I did that and they do work its just when i press the brakes but when i turn the running lights on they dont come on
jrhaden 13.07.2014, 14:27
We're your lights working before you swapped?
Csperry84 14.07.2014, 02:48
Ya and they still are because i just didnt wanna mess anything up the incadesent ones are in now
Csperry84 14.07.2014, 02:51
I thought resistors or a electronic flasher relay would work idk i have resistors and those didnt work they did slow the flasher down though but i havent tried a relay yet but idk why they wouldnt come on they dont require 12v so i dont understand so i just put it back the way it was until i can find a professional
Similar Threads
WTB Drivers Side lx Tail light Lens and Head Light Mounts
WTB: Tail light for Fox
Tail Light Tint
wtb tail light 1994
WTB: 96-98 Passanger Tail Light
Copyright © 2006-2019, Ford Mustang Forums. Privacy Policy